Configure AnyConnect Remote Access VPN on
FTD
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| ntr oduction

This document describes a configuration for AnyConnect Remote Access VPN on FTD.
Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

e Basic VPN, TLSand IKEv2 knowledge
» Basic Authentication, Authorization, and Accounting (AAA) and RADIUS knowledge
» Experience with Firepower Management Center

Components Used

The information in this document is based on these software and hardware versions:

* CiscoFTD 7.2.0
* CiscoFMC7.2.1
* AnyConnect 4.10



The information in this document was created from the devices in a specific lab environment. All of the
devices used in this document started with a cleared (default) configuration. If your network islive, ensure
that you understand the potential impact of any command.

Background I nformation

This document provides a configuration example for Firepower Threat Defense (FTD) version 7.2.0 and
later, that allows remote access VPN to use Transport Layer Security (TLS) and Internet Key Exchange
version 2 (IKEv2). Asaclient, Cisco AnyConnect can be used, which is supported on multiple platforms.

Configuration

1. Prerequisites

In order to go through Remote Access wizard in Firepower Management Center:

Create a certificate used for server authentication.
Configure RADIUS or LDAP server for user authentication.
Create pool of addresses for VPN users.

Upload AnyConnect images for different platforms.

a) Import the SSL Certificate

Certificates are essential when you configure AnyConnect. The certificate must have Subject Alternative
Name extension with DNS name and/or | P address to avoid errorsin web browsers.

% Note: Only registered Cisco users have access to internal tools and bug information.

There are limitations for manual certificate enrollment:
- On FTD you need the CA certificate before you generate the CSR.
- If the CSR is generated externally, the manual method fails, a different method must be used (PKCS12).

There are several methods to obtain a certificate on FTD appliance, but the safe and easy oneisto create a
Certificate Signing Request (CSR), sign it with a Certificate Authority (CA) and then import certificate
issued for public key, which wasin CSR. Here is how to do that:

» (GO tO Objects > Object Management > PKI > Cert Enrollment , click Add Cert Enrollment.



Add Cert Enroliment (7]

Name*
vpntestbbed.cisco.com
Description
|
CA Information Certificate Parameters Key Revocation

Enrollment Type: | Manual v
[ ] CA Only
Check this option if you do not require an identity certificate fo be created
from this CA
CA Certificate: Ep':“_ Iangreno .. ST2xar
YfPCilB7g

BMAV7Gzdc4VspS6ljirAhbiiaw
dBiQIQmsBeFz9JkF4..b3I8Bo
GN+gMabeY
lt8unaZgY4l20//on88r5IWJIm

Validation Usage: IPsec Client SSL Client [ | SSL Server
| | Skip Check for CA flag in basic constraints of the CA Certificate

|| Allow Overrides

Cancel Save

* Select Enroliment Type and paste Certificate Authority (CA) certificate (the certificate which is used to
sign the CSR).

» Then go to second tab and select custom FQDN and fill al necessary fields, for example:



Add Cert Enrolilment

Name*
vpntesthbed.cisco.com
Description
CA Information Certificate Parameters Key Revocation

Include FQDN:

Include Device's IP Address:
Common Mame (CN):
Organization Unit (OU):
Organization (O):

Locality (L):

State (ST):

Country Code (C):

Email (E)

Use Device Hostname as FODN

vpntestbed.cisco.com

TAC

Mexico

MX

CDMX

MX

: I tac@cisco.com

Include Device's Serial Number | |

|| Allow Overrides

Cancel Save

* On thethird tab, select Key Type, choose name and size. For RSA, 2048 bits is minimum.
* Click save and go tO Devices > Certificates > Add > New Certificate.
» Then select Device, and under cert Enroliment Sel ect the trustpoint which you just created, click Add:



Add New Certificate (7]

Add a new certificate to the device using cert enrollment object which is used to
generate CA and identify certificate.

Device*:
| FTD v

Cert Enroliment®:
I vpntestbed.cisco.com| v ‘ +

Cert Enrollment Details:

MName: vpntestbed.cisco.com

* Later, next to the trustpoint name, click the
icon, then ves, and after that copy CSR to CA and sign it. Certificate must have attributes the same as
normal aHTTPS server.

» After you received the certificate from CA in base64 format, select it from the disk and click import.
When this succeeds, you see:

Hame Domain Enroiiment Type Status
emFTD -

VRntesTod.cico.com ool Selt-Signed o 4o tPCw

b) Configure RADIUS Server

* G0 t0 Objects> Object Management > RADIUS Server Group > Add RADIUS Server Group.



* Fill out the name and add IP address along with shared secret, click save:

Edit RADIUS Server (7]

IP Address/Hostname:*

Configure DNS at Threat Defense Platform Settings to resolve hostname
Authentication Port:* (1-65535)
| 1812 |

Confirm Key:*

Accounting Port: (1-65535)
1813

Timeout: (1-300) Seconds
10

Connect using:
(® Routing () Specific Interface @

Default: Management/Diagnostic b

Redirect ACL:

| Cancel | Save

 After that you see the server on thelist:



Narmé Value

RadiusServer 1 Server Su

c) Create a Pool of Addressesfor VPN Users

¢ (GO tO Objects > Object Management > Address Pools > Add | Pv4 Pools.
* Put the name and range, mask is not needed:

Name*

I vpn_pool

IPv4 Address Range*
1072, -10.72,
Mask

‘ Specify a netmask in X.X. XX format

Description

Allow Overrides

. Configure device overrides in the address pool object to
avoid IP address conflicts in case of object is shared across
multiple devices

» Override (0)

d) Create XML Profile

» Download the Profile Editor from Cisco site and open it.
* GO to Server List > Add...
» Put Display Name and FQDN. Y ou see entries in Server List:



[4 AnyConnect Profile Editer - VPN

— O >
File Help
VPN | Server List
: {5‘2 Preferences (Part 1) Profile: C:\Users\calo\Documents\Anyconnect_profile.xml
s Preferences (Part 2) -
% Backup Servers
: 'n E:::E:E:E :‘:::;igng Hostname Host Address User Group Backup Server List  SCEP Maobile Settings Certificate Pins

= Certificate Enrollment
Mobile Policy
- ol Server List

VPN (S5L)
VPN(IPSEC)

vpntestbed.dsco. ...
vpntestbed.cisco....

-- Inherited --
— Inherited —

Mote: it is highly recommended that at least one server be defined in a profile.

* Click okand File> Saveas...

€) Upload AnyConnect I mages

» Download pkg images from Cisco site.

¢ (GO to Objects > Object Management > VPN > AnyConnect File > Add AnyConnect File.
» Typethe name and select PKG file from disk, click save:

Add...

Delete

Details




Edit AnyConnect File Q

MName:*

I Wnyconnectmac4.10 ‘

File Name:*

‘ anyconnect-macos-4.10.06079-webdef ‘ | Browse..
File Type:*

| AnyConnect Client Image v |
Description:

| Cancel |

» Add more packages based on your own requirements.

2. Remote Access Wizard

* (GO tO Devices> VPN > Remote Access > Add a new configuration.
» Name the profile and select FTD device:



Targeted Devices and Protocols

This wizard will guide you through the required minimal steps to configure the Remote
Access VPN policy with a new user-defined connection profile.

Mame:*

Anyconnect_RA

Description:

VPN Protocols:

SSL
IPsec-IKEv2

Targeted Devices:

Available Devices Selected Devices
| Q_ Search | FTD ]
FTD

* In Connection Profile step, type Connection Profile Name, Select the Authentication Server and Address Pools that
you created earlier:



Connection Profile:

Connection Profiles specify the tunnel group policies for a VPN connection. These policies pertain to creating the
tunnel itself, how AAA is accomplished and how addresses are assigned. They also include user attributes, which
are defined in group policies.

Connection Profile Name:* | Anyconnect_RA

I @ This name is configured as a connection alias, it can be used to connect to the VPN gateway

Authentication, Authorization & Accounting (AAA):

Specify the method of authentication (AAA, certificates or both), and the AAA servers that will be used for VPN
connections.

Authentication Method: [ AAA Only v l

RadiusServer v l -+
(LOCAL or Realm or RADIUS)
[ Fallback to LOCAL Authentication

Authentication Server:*

Authorization Server: | Use same authentication server | +
(Realm or RADIUS)

Accounting Server: | v | -
(RADIUS)

Client Address Assignment:

Client IP address can be assigned from AAA server, DHCP server and IP address pools. When multiple options are
selected, IP address assignment is tried in the order of AAA server, DHCP server and IP address pool.

] Use AAA Server (Realm or RADIUS only) @
[ ] Use DHCP Servers
Use IP Address Pools

IPvd Address Pools: | vpn_pool

N

|
IPv6 Address Pools: | l

Group Policy:

A group policy is a collection of user-oriented session attributes which are assigned to client when a VPN
connection is established. Select or create a Group Policy object.

Group Policy:* DfitGrpPolicy v | +

Edit Group Policy

* Click on Edit Group Policy and on the tab AnyConnect, select Client Profile, then click save:



Edit Group Policy (7]

Name:*
DfitGrpPolicy

Description:

General AnyConnect Advanced

Profile
_ AnyConnect profiles contains settings for the VPN client functionality and

Management Profile = optional features. Firewall Threat Defense deploys the profiles during
AnyConnect client connection.

Client Modules

SSL Settings Client Profile:

Connection Settings Anyconnect_profile v | +

Custom Attributes Standalone profile editor can be used to create a new or modify existing

AnyConnect profile. You can download the profile editor from Cisco Software
Download Center.

» On the next page, select AnyConnect images and click Next.

AnyConnect Client Image

The VPN gateway can automatically download the latest AnyConnect package to the client device when the VPN
connection is initiated. Minimize connection setup time by choosing the appropriate OS for the selected package.

Download AnyConnect Client packages from Cisco Software Download Center.

Show Re-order buttons 4

AnyConnect File Object Name AnyConnect Client Package Name Operating System

Anyconnectmac4.10 anyconnect-macos-4.10.06079-webdeploy... Mac OS A ‘

¢ On the next screen, select Network I nterface and Device Certificates:



Network Interface for Incoming VPN Access

Select or create an Interface Group or a Security Zone that contains the network interfaces users
will access for VPN connections.

Interface group/Security Zone:* | Outsied v | +

Enable DTLS on member interfaces

A All the devices must have interfaces as part of the Interface Group/Security Zone selected.

Device Certificates

Device certificate (also called Identity certificate) identifies the VPN gateway to the remote access
clients. Select a certificate which is used to authenticate the VPN gateway.

Certificate Enrollment:* vpntestbed.cisco.com v | +

Access Control for VPN Traffic

All decrypted traffic in the VPN tunnel is subjected to the Access Control Policy by default. Select
this option to bypass decrypted traffic from the Access Control Policy.

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
This option bypasses the Access Control Policy inspection, but VPN filter ACL and
authorization ACL downloaded from AAA server are still applied to VPN traffic.

* When everything is configured correctly, you can click Finish and then Deploy:



AnyConnect

© 5 —9 ] -
r Y AR B O
Remote Outside VPN I i

User Client

Remote Access VPN Policy Configuration

Firepower Management Center will configure an RA VPN Policy with the following settings

Name: Anyconnect_RA

Device Targets: FTD

Connection Profile: Anyconnect_RA
Connection Alias: Anyconnect_RA
AAA:

Authentication Method:  AAA Only
Authentication Server: RadiusServer (RADIUS)

Authorization Server: RadiusServer (RADIUS)
Accounting Server; =
Address Assignment:
Address from AAA: -
DHCP Servers: -

Address Pools (IPvd): vpn_pool
Address Pools (IPv6): =
Group Policy: DMGrpPolicy
AnyConnect Images: Anyconnectmac4.10
Interface Objects: Outsied
Device Certificates: vpntestbed.cisco.com

Device Identity Certificate Enrollment

Certificate enrollment object 'vpntestbed.cisco.com’ is not installed on one or more
targeted devices. Certificate installation will be initiated on the targeted devices on
finishing the wizard. Go to the Certificates page to check the status of the installation.

Device

5

ABA

Additional Configuration Requirements

After the wizard completes, the following
configuration needs to be completed for VPN to
work on all device targets.

@ Access Control Policy Update

An Access Control rule must be defined to allow
VPN traffic on all targeted devices.

© NAT Exemption

If MAT is enabled on the targeted devices, you
must define a NAT Policy to exempt VPN traffic.

@ DNS Configuration

To resolve hostname specified in AAA Servers
or CA Servers, configure DNS using FlexConfig
Policy on the targeted devices.

@ Port Configuration

SSL will be enabled on port 443.

IPsec-IKEv2 uses port 500 and Client Services
will be enabled on port 443 for Anyconnect
image download.NAT-Traversal will be enabled
by default and will use port 4500.

Please ensure that these ports are not used in
NAT Policy or other services before deploying
the configuration.

A Network Interface Configuration

Make sure to add interface from targeted
devices to SecurityZone object 'Outsied’

» This copies the whole configuration along with certificates and AnyConnect packagesto FTD

appliance.

Connection

To connect to FTD you need to open a browser, type DNS name or | P address that points to the outside
interface. Y ou then log in with credentials stored in RADIUS server and do the instructions on the
screen. Once AnyConnect installs, you then need to put the same address in AnyConnect window and click

Connect.

Limitations

Currently unsupported on FTD, but available on ASA:

» FTDposture VPN does not support group policy change through dynamic authorization or RADIUS

change of authorization (CoA).

» AnyConnect customization (Enhancement: Cisco bug ID CSCvg87631)

» AnyConnect scripts (Enhancement: Cisco bug ID CSCvt58044).

» AnyConnect |localization.


https://tools.cisco.com/bugsearch/bug/CSCvq87631
https://tools.cisco.com/bugsearch/bug/CSCvt58044

* WSA integration.

» Simultaneous IKEv2 dynamic crypto map for RA and L2L VPN (Enhancement: Cisco bug
ID CSCvr52047).

» TACACS, Kerberos - KCD Authentication and RSA SDI (Enhancement: Cisco bug ID
CSCvx55859).

» Browser Proxy.

Security consider ations

By default, the sysopt connection permit-vpnoption is disabled. This means, that you need to alow the traffic that
comes from the pool of addresses on outside interface via Access Control Policy. Although the pre-filter or
access-control rule is added to allow VPN traffic only, if clear-text traffic happens to match the rule criteria,
it iserroneously permitted.

There are two approaches to this problem. First, TAC recommended option, isto enable Anti-Spoofing (on
ASA it was known as Unicast Reverse Path Forwarding - uRPF) for outside interface, and secondly, isto
enabl e sysopt connection permit-vpn t0 bypass Snort inspection completely. The first option allows a normal
inspection of the traffic that goes to and from VPN users.

a) Enable uRPF

* Create anull route for the network used for remote access users, defined in section C. Go tO Devices>
Device Management > Edit > Routing > Static Route and Select Add route


https://tools.cisco.com/bugsearch/bug/CSCvr52047
https://tools.cisco.com/bugsearch/bug/CSCvx55859

Add Static Route Configuration 7

Type: @ IPvd () IPV6
Interface*
\ Nullo v \

(Interface starting with this icon [ signifies it is available for route leak)

Available Network . Selected Network

Q, Search ‘ Add ‘ objvpnusers v
any-ipv4
FMC
GW

IPvd-Benchmark-Tests
IPvd-Link-Local
IPvd-Multicast

Gateway*

Metric:
1

(1 -254)

Tunneled: [ | (Used only for default Route)

Route Tracking:

» Next, enable uRPF on the interface where the VPN connections terminate. To find this, navigate to
Devices > Device Management > Edit > | nterfaces > Edit > Advanced > Security Configuration > Enable Anti Spoofing.



Edit Physical Interface L]

General IPvd IPvB Path Monitoring Hardware Configuration Manager Access Advanced
I

Information ARP Security Configuration

Enable Anti Spoofing:
Allow Full Fragment Reassembly: ||

Override Default Fragment Setting: [_|

‘ Cancel |

When a user is connected, the 32-bit route is installed for that user in the routing table. Clear the text traffic
sourced from the other, unused | P addresses from the pool is dropped by URFP. To see a description of Anti-
spoofingrefer to Set Security Configuration Parameters on Firepower Threat Defense.

b) Enable sysopt connection permit-vpn Option

» Thereisan option to do it with the wizard or under Devices> VPN > Remote Access > VPN Profile > Access
Interfaces.

Access Control for VPN Traffic

Bypass Access Control policy for decrypted traffic (sysopt permit-vpn)
Decrypted traffic is subjected to Access Control Policy by default. This option
bypasses the inspection, but VPN Filter ACL and authorization ACL downloaded from
AdLd sernver are still applied to VBN traffic.

Related | nfor mation

» Cisco Technical Support & Downloads



https://www.cisco.com/c/en/us/td/docs/security/secure-firewall/management-center/device-config/720/management-center-device-config-72/interfaces-settings-ifcs-firewall.html?bookSearch=true
https://www.cisco.com/c/en/us/support/index.html?referring_site=bodynav

